use strict;
my $str = 'Agalma elegans
Frillagalma vityazi
Cordagalma tottoni';
my $regex = qr/galma|rillagalma|ordagalma/mp;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";