re = /galma|rillagalma|ordagalma/m
str = 'Agalma elegans
Frillagalma vityazi
Cordagalma tottoni'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result