import re
regex = re.compile(r"galma|rillagalma|ordagalma", flags=re.MULTILINE)
test_str = ("Agalma elegans\n"
"Frillagalma vityazi\n"
"Cordagalma tottoni")
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)