#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!\A)|id:\s*')[^'\s]*\K\s(?=[^']*')"
Local $sString = "var user1 = {id: 'Alan Banks'};" & @CRLF & _
"var user2 = {id: 'Chris Daily'};" & @CRLF & _
"var user1 = {id: 'Alan Banks TEXT here'};" & @CRLF & _
"var user2 = {id: 'Chris Daily More text'};"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)