$re = '/(?:\G(?!\A)|id:\s*\')[^\'\s]*\K\s(?=[^\']*\')/m';
$str = 'var user1 = {id: \'Alan Banks\'};
var user2 = {id: \'Chris Daily\'};
var user1 = {id: \'Alan Banks TEXT here\'};
var user2 = {id: \'Chris Daily More text\'};';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;