using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!\A)|id:\s*')[^'\s]*\K\s(?=[^']*')";
string substitution = @"_";
string input = @"var user1 = {id: 'Alan Banks'};
var user2 = {id: 'Chris Daily'};
var user1 = {id: 'Alan Banks TEXT here'};
var user2 = {id: 'Chris Daily More text'};";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}