import Foundation
let pattern = #"(?:\G(?!\A)|id:\s*')[^'\s]*\K\s(?=[^']*')"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
var user1 = {id: 'Alan Banks'};
var user2 = {id: 'Chris Daily'};
var user1 = {id: 'Alan Banks TEXT here'};
var user2 = {id: 'Chris Daily More text'};
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)