const regex = /(?:\G(?!\A)|id:\s*')[^'\s]*\K\s(?=[^']*')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)|id:\\s*\')[^\'\\s]*\\K\\s(?=[^\']*\')', 'gm')
const str = `var user1 = {id: 'Alan Banks'};
var user2 = {id: 'Chris Daily'};
var user1 = {id: 'Alan Banks TEXT here'};
var user2 = {id: 'Chris Daily More text'};`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);