#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^#\s*|\s*#?$"
Local $sString = "# this is a test " & @CRLF & _
"#this is a test" & @CRLF & _
"# this is a test#" & @CRLF & _
"# this is a test #"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)