use strict;
my $str = '# this is a test
#this is a test
# this is a test#
# this is a test #';
my $regex = qr/^#\s*|\s*#?$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";