re = /^#\s*|\s*#?$/m
str = '# this is a test
#this is a test
# this is a test#
# this is a test #'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result