package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^#\s*|\s*#?$`)
var str = `# this is a test
#this is a test
# this is a test#
# this is a test #`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}