$re = '/^#\s*|\s*#?$/m';
$str = '# this is a test
#this is a test
# this is a test#
# this is a test #';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;