#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:((?P<p1>(?:\( ?)?+)(?:\+|00)?(54)(?<p2>(?: ?\))?+)(?P<sep>(?:[-.]| (?:[-.] )?)?+)(?:(?&p1)(9)(?&p2)(?&sep))?|(?&p1)(0)(?&p2)(?&sep))?+(?&p1)(11|([23]\d{2}(\d)??|(?(-10)(?(-5)(?!)|[68]\d{2})|(?!))))(?&p2)(?&sep)(?(-5)|(?&p1)(15)(?&p2)(?&sep))?(?:([3-6])(?&sep)|([12789]))(\d(?(-5)|\d(?(-6)|\d)))(?&sep)(\d{4})|(1\d{2}|911))$"
Local $sString = "+54 11 4444-0000" & @CRLF & _
"+54 341 1118888" & @CRLF & _
"(+549261)1234567" & @CRLF & _
"(0351)333-4444" & @CRLF & _
"266 - 999 - 0000" & @CRLF & _
"343-1238888" & @CRLF & _
"+5491188884444" & @CRLF & _
"543412228888" & @CRLF & _
"(54)233-15-111-2222" & @CRLF & _
"(+54-343)9990000" & @CRLF & _
"+54 (3436) 99-0000" & @CRLF & _
"(0)8003337333" & @CRLF & _
"11-4-9876543" & @CRLF & _
"+54 11(4444)0000" & @CRLF & _
"+54 341 1111-888" & @CRLF & _
"(+54261)12-34567" & @CRLF & _
"(03510)3334444" & @CRLF & _
"266-99-0000" & @CRLF & _
"4444-5555" & @CRLF & _
"34-5555-0000" & @CRLF & _
"444-5555"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")