import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:((?P<p1>(?:\\( ?)?+)(?:\\+|00)?(54)(?<p2>(?: ?\\))?+)(?P<sep>(?:[-.]| (?:[-.] )?)?+)(?:(?&p1)(9)(?&p2)(?&sep))?|(?&p1)(0)(?&p2)(?&sep))?+(?&p1)(11|([23]\\d{2}(\\d)??|(?(-10)(?(-5)(?!)|[68]\\d{2})|(?!))))(?&p2)(?&sep)(?(-5)|(?&p1)(15)(?&p2)(?&sep))?(?:([3-6])(?&sep)|([12789]))(\\d(?(-5)|\\d(?(-6)|\\d)))(?&sep)(\\d{4})|(1\\d{2}|911))$";
final String string = "+54 11 4444-0000\n"
+ "+54 341 1118888\n"
+ "(+549261)1234567\n"
+ "(0351)333-4444\n"
+ "266 - 999 - 0000\n"
+ "343-1238888\n"
+ "+5491188884444\n"
+ "543412228888\n"
+ "(54)233-15-111-2222\n"
+ "(+54-343)9990000\n"
+ "+54 (3436) 99-0000\n"
+ "(0)8003337333\n"
+ "11-4-9876543\n"
+ "+54 11(4444)0000\n"
+ "+54 341 1111-888\n"
+ "(+54261)12-34567\n"
+ "(03510)3334444\n"
+ "266-99-0000\n"
+ "4444-5555\n"
+ "34-5555-0000\n"
+ "444-5555";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}