re = /^(?:((?P<p1>(?:\( ?)?+)(?:\+|00)?(54)(?<p2>(?: ?\))?+)(?P<sep>(?:[-.]| (?:[-.] )?)?+)(?:(?&p1)(9)(?&p2)(?&sep))?|(?&p1)(0)(?&p2)(?&sep))?+(?&p1)(11|([23]\d{2}(\d)??|(?(-10)(?(-5)(?!)|[68]\d{2})|(?!))))(?&p2)(?&sep)(?(-5)|(?&p1)(15)(?&p2)(?&sep))?(?:([3-6])(?&sep)|([12789]))(\d(?(-5)|\d(?(-6)|\d)))(?&sep)(\d{4})|(1\d{2}|911))$/m
str = '+54 11 4444-0000
+54 341 1118888
(+549261)1234567
(0351)333-4444
266 - 999 - 0000
343-1238888
+5491188884444
543412228888
(54)233-15-111-2222
(+54-343)9990000
+54 (3436) 99-0000
(0)8003337333
11-4-9876543
+54 11(4444)0000
+54 341 1111-888
(+54261)12-34567
(03510)3334444
266-99-0000
4444-5555
34-5555-0000
444-5555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end