package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?-s)^(1\..+)((?s).+?)^(4\..+)`)
var str = `N06
Какое общее ... (куча текста) приспособления:
1. такелажная оснастка
2. приспособления для грузоподъемных операций;
3. захваты;
4. приспособления для грузоподъемных операций;
N07
При эксплуатации ...(куча текста) крановщику,:
1. ознакомленному под роспись с порядком применения ключ-марки;
2. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;
3. выполняющему работы по наряду-допуску
4. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;
`
var substitution = "$3$2$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}