const regex = /(?-s)^(1\..+)((?s).+?)^(4\..+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?-s)^(1\\..+)((?s).+?)^(4\\..+)', 'gm')
const str = `N06
Какое общее ... (куча текста) приспособления:
1. такелажная оснастка
2. приспособления для грузоподъемных операций;
3. захваты;
4. приспособления для грузоподъемных операций;
N07
При эксплуатации ...(куча текста) крановщику,:
1. ознакомленному под роспись с порядком применения ключ-марки;
2. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;
3. выполняющему работы по наряду-допуску
4. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;
`;
const subst = `$3$2$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);