re = /(?-s)^(1\..+)((?s).+?)^(4\..+)/m
str = 'N06
Какое общее ... (куча текста) приспособления:
1. такелажная оснастка
2. приспособления для грузоподъемных операций;
3. захваты;
4. приспособления для грузоподъемных операций;
N07
При эксплуатации ...(куча текста) крановщику,:
1. ознакомленному под роспись с порядком применения ключ-марки;
2. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;
3. выполняющему работы по наряду-допуску
4. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;
'
subst = '$3$2$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result