import re
regex = re.compile(r"(?-s)^(1\..+)((?s).+?)^(4\..+)", flags=re.MULTILINE)
test_str = ("N06\n\n"
"Какое общее ... (куча текста) приспособления:\n"
"1. такелажная оснастка\n"
"2. приспособления для грузоподъемных операций;\n"
"3. захваты;\n"
"4. приспособления для грузоподъемных операций;\n"
"N07\n\n"
"При эксплуатации ...(куча текста) крановщику,:\n"
"1. ознакомленному под роспись с порядком применения ключ-марки;\n"
"2. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;\n"
"3. выполняющему работы по наряду-допуску\n"
"4. получившему в установленном владельцем грузоподъемного крана порядке ключ-марку;\n")
subst = "$3$2$1"
result = regex.sub(subst, test_str)
if result:
print(result)