using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/((\w+)/)?(\w+)\.(\w{3})$";
string input = @"c:/my_project/sources/hr/manage_employees.pks
c:/my_project/sources/hr/manage_employees.pkb
c:/my_project/sources/hr/employee_typ.tps
c:/my_project/sources/hr/employee_typ.tpb
c:/my_project/sources/hotel/manage_rooms.pks
c:/my_project/sources/hotel/manage_rooms.pkb
c:/my_project/tests/hr/test_manage_employees.pks
c:/my_project/tests/hr/test_manage_employees.pkb
c:/my_project/tests/hotel/test_manage_rooms.pks
c:/my_project/tests/hotel/test_manage_rooms.pkb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}