const regex = new RegExp('/((\\w+)/)?(\\w+)\\.(\\w{3})$', 'gm')
const str = `c:/my_project/sources/hr/manage_employees.pks
c:/my_project/sources/hr/manage_employees.pkb
c:/my_project/sources/hr/employee_typ.tps
c:/my_project/sources/hr/employee_typ.tpb
c:/my_project/sources/hotel/manage_rooms.pks
c:/my_project/sources/hotel/manage_rooms.pkb
c:/my_project/tests/hr/test_manage_employees.pks
c:/my_project/tests/hr/test_manage_employees.pkb
c:/my_project/tests/hotel/test_manage_rooms.pks
c:/my_project/tests/hotel/test_manage_rooms.pkb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}