import re
regex = re.compile(r"/((\w+)/)?(\w+)\.(\w{3})$", flags=re.MULTILINE)
test_str = ("c:/my_project/sources/hr/manage_employees.pks\n"
"c:/my_project/sources/hr/manage_employees.pkb\n"
"c:/my_project/sources/hr/employee_typ.tps\n"
"c:/my_project/sources/hr/employee_typ.tpb\n"
"c:/my_project/sources/hotel/manage_rooms.pks\n"
"c:/my_project/sources/hotel/manage_rooms.pkb\n"
"c:/my_project/tests/hr/test_manage_employees.pks\n"
"c:/my_project/tests/hr/test_manage_employees.pkb\n"
"c:/my_project/tests/hotel/test_manage_rooms.pks\n"
"c:/my_project/tests/hotel/test_manage_rooms.pkb")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")