import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/((\\w+)/)?(\\w+)\\.(\\w{3})$";
final String string = "c:/my_project/sources/hr/manage_employees.pks\n"
+ "c:/my_project/sources/hr/manage_employees.pkb\n"
+ "c:/my_project/sources/hr/employee_typ.tps\n"
+ "c:/my_project/sources/hr/employee_typ.tpb\n"
+ "c:/my_project/sources/hotel/manage_rooms.pks\n"
+ "c:/my_project/sources/hotel/manage_rooms.pkb\n"
+ "c:/my_project/tests/hr/test_manage_employees.pks\n"
+ "c:/my_project/tests/hr/test_manage_employees.pkb\n"
+ "c:/my_project/tests/hotel/test_manage_rooms.pks\n"
+ "c:/my_project/tests/hotel/test_manage_rooms.pkb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}