package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/((\w+)/)?(\w+)\.(\w{3})$`)
var str = `c:/my_project/sources/hr/manage_employees.pks
c:/my_project/sources/hr/manage_employees.pkb
c:/my_project/sources/hr/employee_typ.tps
c:/my_project/sources/hr/employee_typ.tpb
c:/my_project/sources/hotel/manage_rooms.pks
c:/my_project/sources/hotel/manage_rooms.pkb
c:/my_project/tests/hr/test_manage_employees.pks
c:/my_project/tests/hr/test_manage_employees.pkb
c:/my_project/tests/hotel/test_manage_rooms.pks
c:/my_project/tests/hotel/test_manage_rooms.pkb`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}