#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(({FUNC\s+(.+?)}|{\/FUNC}))"
Local $sString = "{FUNC name_of_func}" & @CRLF & _
" text" & @CRLF & _
" text" & @CRLF & _
" text" & @CRLF & _
" {FUNC name_of_func2}text 2{/FUNC}" & @CRLF & _
" text" & @CRLF & _
" text" & @CRLF & _
"{/FUNC}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")