const regex = /(({FUNC\s+(.+?)}|{\/FUNC}))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(({FUNC\\s+(.+?)}|{\\\/FUNC}))', 'gmi')
const str = `{FUNC name_of_func}
text
text
text
{FUNC name_of_func2}text 2{/FUNC}
text
text
{/FUNC}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}