using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(({FUNC\s+(.+?)}|{\/FUNC}))";
string input = @"{FUNC name_of_func}
text
text
text
{FUNC name_of_func2}text 2{/FUNC}
text
text
{/FUNC}";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}