package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(({FUNC\s+(.+?)}|{\/FUNC}))`)
var str = `{FUNC name_of_func}
text
text
text
{FUNC name_of_func2}text 2{/FUNC}
text
text
{/FUNC}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}