import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\{FUNC\\s+(.+?)\\}|\\{\\/FUNC\\}))";
final String string = "{FUNC name_of_func}\n"
+ " text\n"
+ " text\n"
+ " text\n"
+ " {FUNC name_of_func2}text 2{/FUNC}\n"
+ " text\n"
+ " text\n"
+ "{/FUNC}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}