#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?ms)ComputerName\=(?<Computername>[^ ]*)Task.*Message\=(?<Message>.*)"
Local $sString = "10/30/2019 09:49:59 AM" & @CRLF & _
"LogName=Application" & @CRLF & _
"SourceName=RoboticLogging" & @CRLF & _
"EventCode=0" & @CRLF & _
"EventType=2" & @CRLF & _
"Type=Error" & @CRLF & _
"ComputerName=WTWFBW4Y.UNITOPR.UNITINT.TEST.STATEFARM.ORG" & @CRLF & _
"TaskCategory=%1" & @CRLF & _
"OpCode=Info" & @CRLF & _
"RecordNumber=2625907" & @CRLF & _
"Keywords=Classic" & @CRLF & _
"Message="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")