package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?ms)ComputerName\=(?<Computername>[^ ]*)Task.*Message\=(?<Message>.*)`)
var str = `10/30/2019 09:49:59 AM
LogName=Application
SourceName=RoboticLogging
EventCode=0
EventType=2
Type=Error
ComputerName=WTWFBW4Y.UNITOPR.UNITINT.TEST.STATEFARM.ORG
TaskCategory=%1
OpCode=Info
RecordNumber=2625907
Keywords=Classic
Message=`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}