const regex = /(?ms)ComputerName\=(?<Computername>[^ ]*)Task.*Message\=(?<Message>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?ms)ComputerName\\=(?<Computername>[^ ]*)Task.*Message\\=(?<Message>.*)', 'gm')
const str = `10/30/2019 09:49:59 AM
LogName=Application
SourceName=RoboticLogging
EventCode=0
EventType=2
Type=Error
ComputerName=WTWFBW4Y.UNITOPR.UNITINT.TEST.STATEFARM.ORG
TaskCategory=%1
OpCode=Info
RecordNumber=2625907
Keywords=Classic
Message=`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}