use strict;
my $str = '10/30/2019 09:49:59 AM
LogName=Application
SourceName=RoboticLogging
EventCode=0
EventType=2
Type=Error
ComputerName=WTWFBW4Y.UNITOPR.UNITINT.TEST.STATEFARM.ORG
TaskCategory=%1
OpCode=Info
RecordNumber=2625907
Keywords=Classic
Message=';
my $regex = qr/(?ms)ComputerName\=(?<Computername>[^ ]*)Task.*Message\=(?<Message>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}