$re = '/(?ms)ComputerName\=(?<Computername>[^ ]*)Task.*Message\=(?<Message>.*)/m';
$str = '10/30/2019 09:49:59 AM
LogName=Application
SourceName=RoboticLogging
EventCode=0
EventType=2
Type=Error
ComputerName=WTWFBW4Y.UNITOPR.UNITINT.TEST.STATEFARM.ORG
TaskCategory=%1
OpCode=Info
RecordNumber=2625907
Keywords=Classic
Message=';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);