using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\x60\x60\x60ad-([^\n]*)\ntitle:([^\n]*)\n([^\x60]*)\x60\x60\x60";
string input = @"```ad-info
title: Dica
- Tenta focar na lógica e não na programação, como se estiver aprendendo do zero a programar.
- [[JFlap]] pra testar a lógica **apenas**
- Vídeoaulas com professores, alunos são muito rasos.
- Professor recomenda fazer compiladores primeiro.
- Você não pode multiplicar se não sabe somar.
```
## ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}