use strict;
my $str = '```ad-info
title: Dica
- Tenta focar na lógica e não na programação, como se estiver aprendendo do zero a programar.
- [[JFlap]] pra testar a lógica **apenas**
- Vídeoaulas com professores, alunos são muito rasos.
- Professor recomenda fazer compiladores primeiro.
- Você não pode multiplicar se não sabe somar.
```
## ';
my $regex = qr`(?s)\x60\x60\x60ad-([^\n]*)\ntitle:([^\n]*)\n([^\x60]*)\x60\x60\x60`p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}