package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)\x60\x60\x60ad-([^\n]*)\ntitle:([^\n]*)\n([^\x60]*)\x60\x60\x60`)
var str = `\`\`\`ad-info
title: Dica
- Tenta focar na lógica e não na programação, como se estiver aprendendo do zero a programar.
- [[JFlap]] pra testar a lógica **apenas**
- Vídeoaulas com professores, alunos são muito rasos.
- Professor recomenda fazer compiladores primeiro.
- Você não pode multiplicar se não sabe somar.
\`\`\`
## `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}