// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)\x60\x60\x60ad-([^\n]*)\ntitle:([^\n]*)\n([^\x60]*)\x60\x60\x60").unwrap();
let string = "```ad-info
title: Dica
- Tenta focar na lógica e não na programação, como se estiver aprendendo do zero a programar.
- [[JFlap]] pra testar a lógica **apenas**
- Vídeoaulas com professores, alunos são muito rasos.
- Professor recomenda fazer compiladores primeiro.
- Você não pode multiplicar se não sabe somar.
```
## ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}