import Foundation
let pattern = #"(?s)\x60\x60\x60ad-([^\n]*)\ntitle:([^\n]*)\n([^\x60]*)\x60\x60\x60"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ###"""
```ad-info
title: Dica
- Tenta focar na lógica e não na programação, como se estiver aprendendo do zero a programar.
- [[JFlap]] pra testar a lógica **apenas**
- Vídeoaulas com professores, alunos são muito rasos.
- Professor recomenda fazer compiladores primeiro.
- Você não pode multiplicar se não sabe somar.
```
##
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)