#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[^a-zA-Z\n]*[a-zA-Z]){5,}"
Local $sString = "aaaaa" & @CRLF & _
"aaa1aa" & @CRLF & _
"aaa" & @CRLF & _
"aaaa" & @CRLF & _
"aa2df445435----5d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")