$re = '/(?:[^a-zA-Z\n]*[a-zA-Z]){5,}/m';
$str = 'aaaaa
aaa1aa
aaa
aaaa
aa2df445435----5d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);