using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^a-zA-Z\n]*[a-zA-Z]){5,}";
string input = @"aaaaa
aaa1aa
aaa
aaaa
aa2df445435----5d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}