package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^a-zA-Z\n]*[a-zA-Z]){5,}`)
var str = `aaaaa
aaa1aa
aaa
aaaa
aa2df445435----5d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}