re = /(?:[^a-zA-Z\n]*[a-zA-Z]){5,}/m
str = 'aaaaa
aaa1aa
aaa
aaaa
aa2df445435----5d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end