#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(blockquote)>(?:(?!<\1>).)+?<a[^>]*>.*?</\1>"
Local $sString = "<blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote>" & @CRLF & _
"<blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote><blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote>" & @CRLF & _
"<blockquote><p>333: <a href="444">h555</a></p></blockquote><blockquote>111</blockquote><p>222</p>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")