re = /<(blockquote)>(?:(?!<\1>).)+?<a[^>]*>.*?<\/\1>/m
str = '<blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote>
<blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote><blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote>
<blockquote><p>333: <a href="444">h555</a></p></blockquote><blockquote>111</blockquote><p>222</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end