const regex = new RegExp('<(blockquote)>(?:(?!<\\1>).)+?<a[^>]*>.*?</\\1>', 'gm')
const str = `<blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote>
<blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote><blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote>
<blockquote><p>333: <a href="444">h555</a></p></blockquote><blockquote>111</blockquote><p>222</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}