using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(blockquote)>(?:(?!<\1>).)+?<a[^>]*>.*?</\1>";
string input = @"<blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href=""444"">h555</a></p></blockquote>
<blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href=""444"">h555</a></p></blockquote><blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href=""444"">h555</a></p></blockquote>
<blockquote><p>333: <a href=""444"">h555</a></p></blockquote><blockquote>111</blockquote><p>222</p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}