$re = '~<(blockquote)>(?:(?!<\1>).)+?<a[^>]*>.*?</\1>~m';
$str = '<blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote>
<blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote><blockquote>111</blockquote><p>222</p><blockquote><p>333: <a href="444">h555</a></p></blockquote>
<blockquote><p>333: <a href="444">h555</a></p></blockquote><blockquote>111</blockquote><p>222</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);